$re = '/[a-zA-Z]+|".*?"/m';
$str = 'we found "the little cat" is in the hat, we like "the little cat"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);