$re = '/(?<=\[)\d+(?=\])/m';
$str = '[2019-07-29 09:48:11,928] @hr.com [2] [AM] WARN
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);