re = /(?<=\[)\d+(?=\])/m
str = '[2019-07-29 09:48:11,928] @hr.com [2] [AM] WARN
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end