$re = '/\b((?<=[A-Z]{2} [–-] )|(?<=\(DC\) [–-] )).*?\b[Cc]hapter\b/';
$str = 'Match unknown number of words that lies between two known patterns
I\'m looking to make a regex for use in LibreOffice Writer\'s "Find and Replace" function. LibreOffice version 25.8.4.2.
The text I want to search looks like the following.
008 – San Terremoto CA | 010 - Eastern AK – Joe Jolson Chapter | 011 - Doughtown NY | 012 - Copperville AZ | 014 - Gatorville FL | 015 - Swamptown FL | 018 - District of Columbia (DC) | 019 - Central PA | 041 – Stoddard Mill MA - Cpl Mike G. Paulson Chapter | 041 – District of Columbia (DC) - Cpl Mike G. Paulson Chapter |139 - North Pacific Bay WA |
1. Most of the records end with
a two-letter U.S. state abbreviation, a space, and a pipe.
2. A number of records end with
a two-letter U.S. state abbreviation, a space, a hyphen, a space, unknown number of words separated by spaces, final space, the word "chapter", space, pipe.
"Chapter" may or may not be capitalized.
In records which match the description in "2." above, I want to match any text which follows the two-letter state abbreviation with a name and the word "chapter". Examples of that text is in boldface type above.
I tried a number of things, lastly this:
(?<=\\[A-Z\\]{2})\\\\s-\\\\s\\[\\\\w\\]+\\\\s\\[Chapter|chapter\\]
and
(?<=\\[A-Z\\]{2})\\\\s-\\\\s\\[a-zA-Z\\]+\\\\s\\[Chapter|chapter\\]
It has not yet worked.
I welcome suggestions. Thank you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);