import re
regex = re.compile(r"\b((?<=[A-Z]{2} [–-] )|(?<=\(DC\) [–-] )).*?\b[Cc]hapter\b")
test_str = ("Match unknown number of words that lies between two known patterns\n\n"
"I'm looking to make a regex for use in LibreOffice Writer's \"Find and Replace\" function. LibreOffice version 25.8.4.2. \n\n"
"The text I want to search looks like the following.\n\n"
"008 – San Terremoto CA | 010 - Eastern AK – Joe Jolson Chapter | 011 - Doughtown NY | 012 - Copperville AZ | 014 - Gatorville FL | 015 - Swamptown FL | 018 - District of Columbia (DC) | 019 - Central PA | 041 – Stoddard Mill MA - Cpl Mike G. Paulson Chapter | 041 – District of Columbia (DC) - Cpl Mike G. Paulson Chapter |139 - North Pacific Bay WA |\n\n\n\n"
"1. Most of the records end with \n\n"
"a two-letter U.S. state abbreviation, a space, and a pipe. \n\n"
"2. A number of records end with\n\n"
"a two-letter U.S. state abbreviation, a space, a hyphen, a space, unknown number of words separated by spaces, final space, the word \"chapter\", space, pipe.\n\n"
"\"Chapter\" may or may not be capitalized.\n\n"
"In records which match the description in \"2.\" above, I want to match any text which follows the two-letter state abbreviation with a name and the word \"chapter\". Examples of that text is in boldface type above.\n\n"
"I tried a number of things, lastly this:\n\n"
"(?<=\\[A-Z\\]{2})\\\\s-\\\\s\\[\\\\w\\]+\\\\s\\[Chapter|chapter\\]\n\n"
"and\n\n"
"(?<=\\[A-Z\\]{2})\\\\s-\\\\s\\[a-zA-Z\\]+\\\\s\\[Chapter|chapter\\]\n\n"
"It has not yet worked.\n\n"
"I welcome suggestions. Thank you")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")