#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<img\s+[^>]+>"
Local $sString = "<img src="http://example.com/someimage1.jpeg">" & @CRLF & _
"<img src="http://example.com/someimage2.jpeg">" & @CRLF & _
"<img src="http://test.mydomain.com/project433q325/track/Images/signature.gif">" & @CRLF & _
"<img src="http://example.com/someimage4.jpeg">" & @CRLF & _
"<img style="OVERFLOW: hidden; WIDTH: 0px; MAX-HEIGHT: 0px" alt="" src="http://test.mydomain.com/project433q325/track/Images/signature.gif?id=446&etc=1586624376">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")