using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s+[^>]+>";
string input = @"<img src=""http://example.com/someimage1.jpeg"">
<img src=""http://example.com/someimage2.jpeg"">
<img src=""http://test.mydomain.com/project433q325/track/Images/signature.gif"">
<img src=""http://example.com/someimage4.jpeg"">
<img style=""OVERFLOW: hidden; WIDTH: 0px; MAX-HEIGHT: 0px"" alt="" src=""http://test.mydomain.com/project433q325/track/Images/signature.gif?id=446&etc=1586624376"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}