import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Jan(uary)?|Feb(ruary)?|Mar(ch)?|Apr(il)?|May|Jun(e)?|Jul(y)?|Aug(ust)?|Sep(tember)?|Oct(ober)?|Nov(ember)?| Dec(ember)?)(,?)(\\s\\d{4})";
final String string = "SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER\n"
+ "by\n"
+ "Chih-Ping Tso\n"
+ "B.Tech., Loughborough University of Technology, United Kingdom\n"
+ "(1968)\n"
+ "Submitted in Partial Fulfillment of\n"
+ "the Requirements for the Degree of\n"
+ "Master of Science\n"
+ "at the\n"
+ "Massachusetts Institute of Technology\n"
+ "August 1970\n"
+ "Signature of Author\n"
+ "Department of Nuclear Engineering\n"
+ "Certified by\n"
+ "Thesis Supervisor\n"
+ "Accepted by\n"
+ "Chairman, Departmental Committee\n"
+ "Archives on Graduate Students\n"
+ "MASS. INST. TECH.\n"
+ "SEP 21 1970\n"
+ "LIBRARIES\n\n"
+ "--------------------------------------\n"
+ "FORMATTING VARIABLES AND TYPEFACE VARIATIONS\n"
+ "OF\n"
+ "DOT-MATRIX PRINT AND THEIR EFFECT\n"
+ "ON\n"
+ "READING COMPREHENSION AND READING SPEED\n"
+ "by\n"
+ "James A. Holmes\n"
+ "Dissertation submitted to the Faculty of the\n"
+ "Virginia Polytechnic Institute and State University\n"
+ "in partial fulfillment of the requirements for the degree of\n"
+ "DOCTOR OF EDUCATION\n"
+ "in\n"
+ "Vocational and Technical Education\n"
+ "March, 1986\n"
+ "Blacksburg, Virginia";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}