import re
regex = re.compile(r"(Jan(uary)?|Feb(ruary)?|Mar(ch)?|Apr(il)?|May|Jun(e)?|Jul(y)?|Aug(ust)?|Sep(tember)?|Oct(ober)?|Nov(ember)?| Dec(ember)?)(,?)(\s\d{4})", flags=re.MULTILINE)
test_str = ("SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER\n"
"by\n"
"Chih-Ping Tso\n"
"B.Tech., Loughborough University of Technology, United Kingdom\n"
"(1968)\n"
"Submitted in Partial Fulfillment of\n"
"the Requirements for the Degree of\n"
"Master of Science\n"
"at the\n"
"Massachusetts Institute of Technology\n"
"August 1970\n"
"Signature of Author\n"
"Department of Nuclear Engineering\n"
"Certified by\n"
"Thesis Supervisor\n"
"Accepted by\n"
"Chairman, Departmental Committee\n"
"Archives on Graduate Students\n"
"MASS. INST. TECH.\n"
"SEP 21 1970\n"
"LIBRARIES\n\n"
"--------------------------------------\n"
"FORMATTING VARIABLES AND TYPEFACE VARIATIONS\n"
"OF\n"
"DOT-MATRIX PRINT AND THEIR EFFECT\n"
"ON\n"
"READING COMPREHENSION AND READING SPEED\n"
"by\n"
"James A. Holmes\n"
"Dissertation submitted to the Faculty of the\n"
"Virginia Polytechnic Institute and State University\n"
"in partial fulfillment of the requirements for the degree of\n"
"DOCTOR OF EDUCATION\n"
"in\n"
"Vocational and Technical Education\n"
"March, 1986\n"
"Blacksburg, Virginia")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")