use strict;
my $str = '
PHOENIX Shipping Point Prices as of 21-JUL-2022
Provided by: Specialty Crops Market News
Federal - State Market News Service, USDA.
Phone: (602) 514-7210 Fax: (602)
Prices represent open (spot) market sales by first handlers on product of
generally good quality and condition unless otherwise stated and may include
promotional allowances or other incentives. No consideration is given to
after-sale adjustments unless otherwise stated. Reported prices generally
include, but are not limited to, applicable brokerage fees and commissions,
Customs fees and duties, U.S. packaging and U.S. freight costs prior to first
sale, paid by the shipper/seller. Delivered Sales, Shipping Point Basis
excludes all charges for freight after sale.
IX_FV120
Phoenix, AZ: Cloudy 91-113
Yuma, AZ: Cloudy 87-113
Bakersfield, CA: Sunny 74-105
Coachella, CA: Sunny 86-116
El Centro, CA: Cloudy 85-114
Fresno, CA: Sunny 71-106
Huron, CA: Sunny 64-107
Oxnard, CA: Cloudy 60-69
Salinas, CA: Cloudy 53-70
Santa Maria, CA: Cloudy 52-71
McAllen, TX: Cloudy 79-101
San Antonio, TX: Cloudy 75-103
Culiacan, SI MX: Sunny 82-105
Hermosillo, SO MX: Cloudy 87-110
Veracruz, VE MX: Cloudy 78-89
Villahermosa, TB MX: Cloudy 75-98
CENTRAL CALIFORNIA AND MEXICO CROSSINGS THROUGH SOUTHERN CALIFORNIA AND SAN
LUIS, ARIZONA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---BEETS: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. Most
shipments from Mexico transferred to Central Coast California for consolidation
and distribution. cartons bunched Red Type 12s 12.45-15.85 mostly 12.45-14.00
occasional higher ORGANIC cartons bunched Red Type 12s 13.35-18.50 mostly
13.35-16.50 Gold Type 12s 16.50-18.50
CENTRAL COAST CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---CABBAGE: SUPPLY RED VERY LIGHT. DEMAND FAIRLY LIGHT. MARKET SLIGHTLY LOWER.
Extra services included. Wide range in quality and condition. 50 lb cartons
Round Green Type med 18.00-23.55 mostly 18.50-21.25 Red Type med 30.45-34.05
mostly 30.45-31.55 ORGANIC 45 lb cartons Round Green Type med supplies
insufficient to establish a market Red Type med 22.50-28.75 occasional higher
---ENDIVE: DEMAND LIGHT. MARKET SLIGHTLY LOWER. Extra services included. Wide
range in quality and condition. cartons 24s 9.00-11.75 few 13.45 occasional
higher
---ESCAROLE: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra services included.
Wide range in quality and condition. cartons 24s 12.55-15.50 mostly 12.55-14.25
occasional higher
---GREENS: DEMAND LIGHT. MARKET SLIGHTLY LOWER. Extra services included. Wide
range in quality and condition. cartons bunched Kale green 24s 8.75-12.65
mostly 9.45-10.75 occasional higher ORGANIC cartons bunched Kale green 24s
16.00-18.75 few 22.00 red 24s 16.50-18.50 few 24.00 Lacinato (Tuscan) 24s
16.50-18.75 few 22.00
---ONIONS GREEN: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included.
Wide range in quality and condition. cartons bunched Leeks 12s 14.45-18.95
mostly 15.45-17.65 ORGANIC cartons bunched Leeks 12s 12.35-18.75 mostly
13.85-17.50
---PARSLEY: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. Wide
range in quality and condition. cartons bunched Curly 60s 11.45-15.65 mostly
13.45-15.65 few 16.00-17.00 30s 9.55-13.05 mostly 10.45-12.50 few 14.15-14.25
Plain 60s 13.85-19.65 mostly 15.45-18.55 occasional lower 30s 11.25-17.65
mostly 12.45-16.55 occasional lower ORGANIC cartons bunched Curly 30s
14.00-18.75 mostly 16.00-18.75 occasional higher Plain 30s 14.50-19.55 mostly
16.00-18.95 occasional higher
---SPINACH: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra services included.
Wide range in quality and condition. cartons Flat 24s 8.65-12.85 mostly
8.65-11.50 few 14.00-14.55 occasional lower ORGANIC cartons Flat 24s supplies
insufficient and in too few hands to establish a market
CENTRAL DISTRICT CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---ARTICHOKES: DEMAND MODERATE. MARKET 18S SLIGHTLY HIGHER, OTHERS ABOUT
STEADY. Extra services included. cartons Globe 12s 10.75-14.75 mostly
10.75-13.75 few 16.75 one label 18.55 18s 12.85-16.75 mostly 12.85-15.75 24s
12.55-15.75 mostly 12.55-14.75 few 16.55-16.75 30s 12.55-15.75 mostly
12.55-14.75 few 16.55-16.75 ORGANIC cartons Globe 18s 16.00-22.50 one label
28.55 24s 12.00-22.50 mostly 12.00-18.55
---TOMATOES: DEMAND FAIRLY GOOD. MARKET ABOUT STEADY. Extra services included.
25 lb cartons loose Mature Greens xlge 9.95-12.00 mostly 10.95-12.00 lge
9.95-12.00 mostly 10.95-12.00 med 8.95-11.00 mostly 9.95-10.00
---TOMATOES, PLUM TYPE: SUPPLY VERY LIGHT. DEMAND GOOD. MARKET ABOUT STEADY.
Extra services included. Most present shipments from prior bookings and/or
previous commitments. 25 lb cartons loose Roma exlge 13.00-14.00 lge
13.00-14.00 med 11.00-13.00 mostly 11.00
KERN DISTRICT CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2021 Season
---CARROTS: DEMAND MODERATE. MARKET STEADY. Extra services included. sacks 48
1-lb film bags med-lge 16.00-18.00 50 lb sacks loose jbo 16.00-19.00 one
label 25.55 25 lb sacks loose jbo 8.00-8.50 one label 12.80 cartons 30 1-lb
film bags Baby Peeled 19.20-19.80 ORGANIC sacks 48 1-lb film bags med-lge
22.20-34.35 mostly 22.20-29.35 cartons 24 1-lb film bags Baby Peeled
21.60-22.55 cartons 30 1-lb film bags Baby Peeled 27.00-28.00 cartons 12 2-lb
film bags Baby Peeled 21.60-22.55
MEXICO CROSSINGS THROUGH OTAY MESA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---CUCUMBERS: DEMAND FAIRLY GOOD. MARKET MEDIUM AND 36S SLIGHTLY HIGHER, OTHERS
ABOUT STEADY. Extra services included. Wide reange in quality. 1 1/9 bushel
cartons med 16.95-18.95 mostly 16.95 few 20.95 fr qual 10.95-14.95 mostly
12.95-14.95 occasional higher ord qual 6.95-10.95 mostly 7.95-8.95 lge
14.95-18.95 mostly 14.95-16.95 occasional higher cartons 36s 8.95-10.95 mostly
8.95 ORGANIC cartons 36s 12.95-14.95 mostly 12.95
---TOMATOES: DEMAND GOOD. MARKET ABOUT STEADY. Extra services included. cartons
2 layer Vine Ripes 4x4s 13.00-16.95 mostly 13.00-14.95 4x5s 14.95-15.00 5x5s
12.95-13.00 5x6s 12.95-14.95 mostly 12.95-13.00
---TOMATOES, CHERRY: DEMAND GOOD. MARKET ABOUT STEADY. Extra services included.
flats 12 1-pt baskets med-lge 10.00-12.95 mostly 12.95
---TOMATOES, GRAPE TYPE: DEMAND GOOD. MARKET ABOUT STEADY. Extra services
included. flats 12 1-pt containers with lids med-lge 9.00 20 lb cartons loose
med-lge 16.00-17.00 ORGANIC flats 12 1-pt containers with lids med-lge
7.45-9.00 20 lb cartons loose med-lge 15.95-16.00
---TOMATOES, PLUM TYPE: DEMAND GOOD. MARKET ABOUT STEADY. Extra services
included. Most present shipments from prior bookings and/or previous
commitments. 25 lb cartons loose Roma exlge 14.95-16.95 occasional higher lge
14.95-16.95 mostly 14.95 occasional lower med 12.95-14.95 mostly 12.95
occasional higher
MEXICO CROSSINGS THROUGH SOUTHERN CALIFORNIA AND SAN LUIS, ARIZONA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---ONIONS GREEN: SUPPLY HEAVY. DEMAND LIGHT. MARKET ABOUT STEADY. Extra
services included. Most shipments from Mexico transferred to Central California
for consolidation and distribution. cartons bunched 48s med 6.95-10.85 mostly
7.00-9.55 few 11.00-11.15 one label 12.75 cartons 2 film bags iceless 24
bunches per bag 6.00-12.50 mostly 8.45-10.55 few 13.75 one label 14.25 cartons
4 film bags iceless 12 bunches per bag 6.00-12.50 mostly 8.45-10.55 few 13.75
one label 14.25 ORGANIC cartons bunched 48s med 18.50-20.95 occasional higher
MEXICO CROSSINGS THROUGH TEXAS
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2021 Season
---BROCCOLI: DEMAND MODERATE. MARKET SLIGHTLY LOWER. Wide range in quality and
condition. 20 lb cartons loose Crown Cut Short Trim 13.00-15.50 mostly
14.00-14.50 occasional higher
---CARROTS: DEMAND MODERATE. MARKET ABOUT STEADY. Wide range in price, quality,
and condition. 50 lb sacks loose jbo 13.00-14.00
---CUCUMBERS: DEMAND MODERATE. MARKET ABOUT STEADY. Wide range in price,
quality and condition. Most present shipments from prior bookings and or
previous commitments. 1 1/9 bushel cartons med 11.95-13.95 mostly 11.95-12.95
occasional higher fr qual 6.95-8.95 mostly 7.95-8.95 ord qual 4.95-6.95 mostly
4.95-5.95 lge 10.95-12.95 mostly 10.95-11.95 few 14.95 ocassional higher
---PEPPERS, BELL TYPE: SUPPLY LIGHT. DEMAND RED GOOD, YELLOW AND ORANGE FAIRLY
GOOD. MARKET ORANGE SLIGHTLY HIGHER, OTHERS ABOUT STEADY. Wide range in price
and quality. GREENHOUSE 11 lb cartons Red jbo 16.00-18.00 mostly 17.00-18.00
occasional higher exlge 16.00-18.00 mostly 17.00-18.00 occasional higher lge
15.00-17.00 mostly 15.00-16.00 Yellow jbo 12.00-14.00 mostly 13.00-14.00 exlge
12.00-14.00 mostly 13.00-14.00 Orange jbo 12.00-15.00 mostly 13.00-15.00 exlge
12.00-15.00 mostly 13.00-15.00
---PEPPERS, OTHER: DEMAND GOOD AT SLIGHTLY LOWER PRICES. MARKET SLIGHTLY LOWER.
Wide range in price, quality, condition and size. 1 1/9 bushel cartons Anaheim
26.00-29.00 mostly 27.00-28.00 occasional higher Jalapeno 15.00-18.00 mostly
16.00-17.00 Poblano 16.00-18.00 mostly 17.00-18.00 occasional higher Serrano
15.00-18.00 mostly 16.00-17.00 occasional higher 8 lb cartons Habanero orange
29.00-32.00 mostly 29.00-30.00
---TOMATOES: DEMAND FAIRLY GOOD. MARKET LOOSE MUCH HIGHER, 2 LAYER SLIGHTLY
HIGHER. Extra services included. 25 lb cartons loose Vine Ripes 4x5 sz
14.96-16.95 mostly 15.95-16.95 5x5 sz 14.95-16.95 mostly 15.95-16.95 5x6 sz
13.95-15.95 mostly 14.95 cartons 2 layer Vine Ripes 4x4s 13.95-15.95 mostly
14.95 4x5s 13.95-15.95 mostly 14.95 5x5s 12.95-14.95 mostly 12.95-13.95
---TOMATOES, GRAPE TYPE: DEMAND MODERATE. MARKET PINTS SLIGHTLY HIGHER, OTHERS
ABOUT STEADY. Wide range in quality and condition. flats 12 1-pt containers
with lids med-lge 7.95-9.95 mostly 8.95 20 lb cartons loose med-lge 12.95-14.95
mostly 13.95
---TOMATOES, PLUM TYPE: DEMAND LIGHT. MARKET ABOUT STEADY. Extra services
included. Wide range in quality and condition. 25 lb cartons loose Roma exlge
12.95-13.95 mostly 12.95 occasional higher lge 11.95-12.95 occasional higher
med 10.95-11.95 mostly 10.95 occasional higher
OXNARD DISTRICT CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2021 Season
---CABBAGE: SUPPLY RED LIGHT. DEMAND FAIRLY LIGHT. MARKET RED LOWER, GREEN
SLIGHTLY LOWER. Extra services included. Wide range in quality and condition.
50 lb cartons Round Green Type med 18.95-19.95 Red Type med 26.95-30.95
---GREENS: DEMAND FAIRLY GOOD. MARKET ABOUT STEADY. Extra services included.
cartons bunched Kale green 24s 9.95-11.95 mostly 9.95-10.00 Lacinato (Tuscan)
24s 10.95-13.95 mostly 11.95-13.95
---PARSLEY: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included.
cartons bunched Curly 60s 13.95-16.95 mostly 14.95-16.95 Plain 60s 12.95-16.95
mostly 14.95-16.95
SALINAS-WATSONVILLE CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---BROCCOLI: DEMAND FAIRLY LIGHT. MARKET SLIGHTLY LOWER. Extra services
included. Wide range in quality and condition. cartons bchd 14s 9.55-13.55
mostly 10.00-11.75 few 14.45-14.95 occasional lower bchd 18s 10.05-14.05 mostly
10.50-12.25 few 14.95-15.45 occasional lower 20 lb cartons loose Crown Cut
10.00-14.85 mostly 11.00-12.75 few 15.50-15.95 Short Trim 12.00-15.85 mostly
12.00-13.75 few 16.50-16.95 ORGANIC cartons bchd 14s 14.00-22.50 mostly
16.55-18.75 few 24.95 occasional higher 20 lb cartons loose Crown Cut
18.00-24.75 mostly 20.55-22.75 few 28.50-28.95
---CAULIFLOWER: SUPPLY FAIRLY HEAVY. DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY.
Extra services included. Harvest curtailed by market conditions. cartons film
wrapped White 9s 8.55-11.75 mostly 8.65-10.00 few 12.55 occasional higher and
lower 12s 8.45-12.75 mostly 9.45-10.65 few 13.50-13.55 occasional higher 16s
7.55-11.55 mostly 8.45-9.65 few 12.55 ORGANIC cartons film wrapped White 9s
9.00-16.50 mostly 13.55-15.50 one label 18.95 12s 12.00-17.50 mostly
14.50-15.85 few 18.95 16s 12.00-16.50 mostly 12.00-14.50 one label 18.95
---CELERY: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. Wide
range in quality and condition. cartons 2 dz 12.00-16.75 mostly 13.35-15.00 few
17.50-18.55 occasional lower 2 1/2 dz 12.00-16.75 mostly 14.06-15.50 few
17.50-18.55 occasional lower 3 dz 14.06-17.55 mostly 14.06-16.65 one label
18.45 cartons film bags Hearts 18s 17.06-20.55 mostly 17.50-19.06 few
21.55-22.55 ORGANIC cartons 2 dz 14.00-17.50 mostly 14.50-16.75 few 18.50 one
label 20.95 2 1/2 dz 14.50-17.50 mostly 14.50-16.75 few 18.50-18.56 one label
20.95 cartons film bags Hearts 18s 14.50-18.95 mostly 16.00-17.85 occasional
higher
---LETTUCE-ICEBERG: DEMAND FAIRLY GOOD. MARKET SLIGHTLY HIGHER. Extra services
included. Wide range in quality and condition. cartons flm lined 24s
15.55-18.75 mostly 15.55-17.50 few 19.00-19.65 few 12.00-12.95 24s flmwrpd
16.55-19.75 mostly 16.55-18.50 few 20.00-20.65 few 13.00-13.95 30s flmwrpd
14.00-15.55 mostly 14.00-14.75 occasional higher ORGANIC cartons 24s flmwrpd
16.00-20.50 mostly 16.00-18.50 12s flmwrpd 10.00-12.95 mostly 10.00-11.85
---LETTUCE-OTHER: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra services
included. Wide range in quality and condition. cartons Boston 24s 10.50-14.75
mostly 10.50-12.55 few 15.50-15.75 Green Leaf 24s 8.56-11.95 mostly 9.50-10.65
few 12.06-12.50 one label 15.75 Red Leaf 24s 8.56-11.75 mostly 9.50-10.65 few
12.05-12.75 ORGANIC cartons Green Leaf 24s 12.00-16.75 mostly 12.00-14.75 Red
Leaf 24s 12.00-16.75 mostly 12.00-14.75
---LETTUCE-ROMAINE: DEMAND HEARTS FAIRLY LIGHT, 24S MODERATE. MARKET ABOUT
STEADY. Extra services included. Wide range in quality and condition. cartons
24s 10.00-13.75 mostly 10.15-11.95 occasional higher cartons 12 3-count
packages Hearts 12.85-17.95 mostly 14.50-16.75 few 18.05-18.75 occasional
higher cartons film lined Hearts 48s 13.85-19.95 mostly 16.50-18.75 few
20.00-20.75 ORGANIC cartons 24s 16.50-18.55 few 20.00-20.75 cartons 12 3-count
packages Hearts 13.85-20.50 mostly 17.55-18.95 few 22.50-22.75
SAN JOAQUIN VALLEY CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---CORN-SWEET: SUPPLY VERY LIGHT. DEMAND GOOD. Extra services included.
cartons/crates White 4 dz min 28.95-37.95 mostly 33.95-34.95 occasional higher
---PEPPERS, BELL TYPE: DEMAND GOOD. MARKET ABOUT STEADY. Extra services
included. 1 1/9 bushel cartons Green exlge 24.95-30.95 mostly 28.95 lge
20.95-26.95 mostly 22.95-23.95 irreg sz fr qual 18.95-23.95 mostly 18.95-20.95
occasional higher Red irreg sz fr qual 28.95-32.95 mostly 29.95-30.95
SANTA MARIA CALIFORNIA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---BROCCOLI: DEMAND SHORT TRIM MODERATE, OTHERS LIGHT. MARKET SLIGHTLY LOWER.
Extra services included. cartons bchd 14s 8.50-11.85 mostly 10.00-11.00 20 lb
cartons loose Crown Cut 10.00-13.00 mostly 10.00-12.00 Short Trim 11.00-14.00
mostly 11.00-13.00
---CAULIFLOWER: DEMAND LIGHT. MARKET ABOUT STEADY. Extra services included.
Most present shipments from prior bookings and/or previous commitments. cartons
film wrapped White 9s 6.00-8.00 mostly 6.00-7.00 12s 6.00-9.15 mostly 7.00-8.35
few 10.15
---CELERY: DEMAND MODERATE. MARKET 2 DOZEN ABOUT STEADY, OTHERS SLIGHTLY LOWER.
Extra services included. cartons 2 dz 10.50-14.00 mostly 11.00-12.65 occasional
higher 2 1/2 dz 10.50-14.00 mostly 11.00-12.65 occasional higher 3 dz
10.50-14.00 mostly 10.50-12.50 occasional higher
---LETTUCE-ICEBERG: DEMAND FAIRLY GOOD. MARKET ABOUT STEADY. Extra services
included. Wide range in price, quality and condition. Most present shipments
from prior bookings and/or previous commitments. cartons flm lined 24s
10.00-12.15 mostly 10.00-11.00 occasional higher 24s flmwrpd 11.00-14.15 mostly
11.00-12.65 few 15.00 occasional higher
---LETTUCE-OTHER: SUPPLY VERY LIGHT AND IN FEW HANDS. DEMAND LIGHT. MARKET
LOWER. Extra services included. cartons Green Leaf 24s 8.00-11.85 mostly
9.00-9.50 Red Leaf 24s 9.50-10.85 mostly 9.50
---LETTUCE-ROMAINE: DEMAND LIGHT. MARKET ABOUT STEADY. Extra services included.
cartons 24s 8.00-11.85 mostly 8.00-10.00 cartons 12 3-count packages Hearts
11.00-14.00 mostly 11.00-12.85
SOUTH & CENTRAL CALIFORNIA AND MEXICO CROSSINGS THROUGH SOUTHERN CALIFORNIA
AND SAN LUIS, ARIZONA
Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis
VEGETABLES
2022 Season
---BRUSSELS SPROUTS: DEMAND MODERATE. MARKET ABOUT STEADY. Extra service
included. Wide range in quality and condition. 25 lb cartons med 18.45-23.15
mostly 19.50-21.45 few 24.75-24.95
---PEAS GREEN: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included 10
lb cartons Snow Peas Decalyxed 14.00-20.95 mostly 16.00-18.00 few 21.35
occasional lower Sugar Snap Peas Decalyxed 16.00-18.95 mostly 17.95-18.95 few
21.35 occasional lower
---RADISHES: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra service included.
Wide range in quality and condition. cartons bunched Red 24s 10.95-14.85 mostly
11.95-13.55 occasional higher 48s 16.45-19.25 mostly 17.45-18.95 ';
my $regex = qr/(SALINAS-WATSONVILLE CALIFORNIA(.|\n)*?MARKET(.|\n)*?)\n\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}