# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(SALINAS-WATSONVILLE CALIFORNIA(.|\n)*?MARKET(.|\n)*?)\n\n"
test_str = ("\n"
"PHOENIX Shipping Point Prices as of 21-JUL-2022 \n"
" \n"
"Provided by: Specialty Crops Market News \n"
" Federal - State Market News Service, USDA. \n"
" \n"
"Phone: (602) 514-7210 Fax: (602) \n"
" \n"
"Prices represent open (spot) market sales by first handlers on product of \n"
"generally good quality and condition unless otherwise stated and may include \n"
"promotional allowances or other incentives. No consideration is given to \n"
"after-sale adjustments unless otherwise stated. Reported prices generally \n"
"include, but are not limited to, applicable brokerage fees and commissions, \n"
"Customs fees and duties, U.S. packaging and U.S. freight costs prior to first \n"
"sale, paid by the shipper/seller. Delivered Sales, Shipping Point Basis \n"
"excludes all charges for freight after sale. \n"
" \n\n"
"IX_FV120 \n"
" \n"
"Phoenix, AZ: Cloudy 91-113\n"
"Yuma, AZ: Cloudy 87-113\n"
"Bakersfield, CA: Sunny 74-105\n"
"Coachella, CA: Sunny 86-116\n"
"El Centro, CA: Cloudy 85-114\n"
"Fresno, CA: Sunny 71-106\n"
"Huron, CA: Sunny 64-107\n"
"Oxnard, CA: Cloudy 60-69\n"
"Salinas, CA: Cloudy 53-70\n"
"Santa Maria, CA: Cloudy 52-71\n"
"McAllen, TX: Cloudy 79-101\n"
"San Antonio, TX: Cloudy 75-103\n"
"Culiacan, SI MX: Sunny 82-105\n"
"Hermosillo, SO MX: Cloudy 87-110\n"
"Veracruz, VE MX: Cloudy 78-89\n"
"Villahermosa, TB MX: Cloudy 75-98\n"
" \n"
" \n"
" \n"
" \n\n"
"CENTRAL CALIFORNIA AND MEXICO CROSSINGS THROUGH SOUTHERN CALIFORNIA AND SAN \n"
" LUIS, ARIZONA \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---BEETS: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. Most \n"
"shipments from Mexico transferred to Central Coast California for consolidation\n"
"and distribution. cartons bunched Red Type 12s 12.45-15.85 mostly 12.45-14.00 \n"
"occasional higher ORGANIC cartons bunched Red Type 12s 13.35-18.50 mostly \n"
"13.35-16.50 Gold Type 12s 16.50-18.50 \n\n"
"CENTRAL COAST CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---CABBAGE: SUPPLY RED VERY LIGHT. DEMAND FAIRLY LIGHT. MARKET SLIGHTLY LOWER. \n"
"Extra services included. Wide range in quality and condition. 50 lb cartons \n"
"Round Green Type med 18.00-23.55 mostly 18.50-21.25 Red Type med 30.45-34.05 \n"
"mostly 30.45-31.55 ORGANIC 45 lb cartons Round Green Type med supplies \n"
"insufficient to establish a market Red Type med 22.50-28.75 occasional higher \n"
"---ENDIVE: DEMAND LIGHT. MARKET SLIGHTLY LOWER. Extra services included. Wide \n"
"range in quality and condition. cartons 24s 9.00-11.75 few 13.45 occasional \n"
"higher \n"
"---ESCAROLE: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra services included.\n"
"Wide range in quality and condition. cartons 24s 12.55-15.50 mostly 12.55-14.25\n"
"occasional higher \n"
"---GREENS: DEMAND LIGHT. MARKET SLIGHTLY LOWER. Extra services included. Wide \n"
"range in quality and condition. cartons bunched Kale green 24s 8.75-12.65 \n"
"mostly 9.45-10.75 occasional higher ORGANIC cartons bunched Kale green 24s \n"
"16.00-18.75 few 22.00 red 24s 16.50-18.50 few 24.00 Lacinato (Tuscan) 24s \n"
"16.50-18.75 few 22.00 \n"
"---ONIONS GREEN: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included.\n"
"Wide range in quality and condition. cartons bunched Leeks 12s 14.45-18.95 \n"
"mostly 15.45-17.65 ORGANIC cartons bunched Leeks 12s 12.35-18.75 mostly \n"
"13.85-17.50 \n"
"---PARSLEY: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. Wide\n"
"range in quality and condition. cartons bunched Curly 60s 11.45-15.65 mostly \n"
"13.45-15.65 few 16.00-17.00 30s 9.55-13.05 mostly 10.45-12.50 few 14.15-14.25 \n"
"Plain 60s 13.85-19.65 mostly 15.45-18.55 occasional lower 30s 11.25-17.65 \n"
"mostly 12.45-16.55 occasional lower ORGANIC cartons bunched Curly 30s \n"
"14.00-18.75 mostly 16.00-18.75 occasional higher Plain 30s 14.50-19.55 mostly \n"
"16.00-18.95 occasional higher \n"
"---SPINACH: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra services included. \n"
"Wide range in quality and condition. cartons Flat 24s 8.65-12.85 mostly \n"
"8.65-11.50 few 14.00-14.55 occasional lower ORGANIC cartons Flat 24s supplies\n"
"insufficient and in too few hands to establish a market \n\n"
"CENTRAL DISTRICT CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---ARTICHOKES: DEMAND MODERATE. MARKET 18S SLIGHTLY HIGHER, OTHERS ABOUT \n"
"STEADY. Extra services included. cartons Globe 12s 10.75-14.75 mostly \n"
"10.75-13.75 few 16.75 one label 18.55 18s 12.85-16.75 mostly 12.85-15.75 24s \n"
"12.55-15.75 mostly 12.55-14.75 few 16.55-16.75 30s 12.55-15.75 mostly \n"
"12.55-14.75 few 16.55-16.75 ORGANIC cartons Globe 18s 16.00-22.50 one label \n"
"28.55 24s 12.00-22.50 mostly 12.00-18.55 \n"
"---TOMATOES: DEMAND FAIRLY GOOD. MARKET ABOUT STEADY. Extra services included. \n"
"25 lb cartons loose Mature Greens xlge 9.95-12.00 mostly 10.95-12.00 lge \n"
"9.95-12.00 mostly 10.95-12.00 med 8.95-11.00 mostly 9.95-10.00 \n"
"---TOMATOES, PLUM TYPE: SUPPLY VERY LIGHT. DEMAND GOOD. MARKET ABOUT STEADY. \n"
"Extra services included. Most present shipments from prior bookings and/or \n"
"previous commitments. 25 lb cartons loose Roma exlge 13.00-14.00 lge \n"
"13.00-14.00 med 11.00-13.00 mostly 11.00 \n\n"
"KERN DISTRICT CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2021 Season \n"
"---CARROTS: DEMAND MODERATE. MARKET STEADY. Extra services included. sacks 48 \n"
"1-lb film bags med-lge 16.00-18.00 50 lb sacks loose jbo 16.00-19.00 one \n"
"label 25.55 25 lb sacks loose jbo 8.00-8.50 one label 12.80 cartons 30 1-lb \n"
"film bags Baby Peeled 19.20-19.80 ORGANIC sacks 48 1-lb film bags med-lge \n"
"22.20-34.35 mostly 22.20-29.35 cartons 24 1-lb film bags Baby Peeled \n"
"21.60-22.55 cartons 30 1-lb film bags Baby Peeled 27.00-28.00 cartons 12 2-lb\n"
"film bags Baby Peeled 21.60-22.55 \n\n"
"MEXICO CROSSINGS THROUGH OTAY MESA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---CUCUMBERS: DEMAND FAIRLY GOOD. MARKET MEDIUM AND 36S SLIGHTLY HIGHER, OTHERS\n"
"ABOUT STEADY. Extra services included. Wide reange in quality. 1 1/9 bushel \n"
"cartons med 16.95-18.95 mostly 16.95 few 20.95 fr qual 10.95-14.95 mostly \n"
"12.95-14.95 occasional higher ord qual 6.95-10.95 mostly 7.95-8.95 lge \n"
"14.95-18.95 mostly 14.95-16.95 occasional higher cartons 36s 8.95-10.95 mostly \n"
"8.95 ORGANIC cartons 36s 12.95-14.95 mostly 12.95 \n"
"---TOMATOES: DEMAND GOOD. MARKET ABOUT STEADY. Extra services included. cartons\n"
"2 layer Vine Ripes 4x4s 13.00-16.95 mostly 13.00-14.95 4x5s 14.95-15.00 5x5s \n"
"12.95-13.00 5x6s 12.95-14.95 mostly 12.95-13.00 \n"
"---TOMATOES, CHERRY: DEMAND GOOD. MARKET ABOUT STEADY. Extra services included.\n"
"flats 12 1-pt baskets med-lge 10.00-12.95 mostly 12.95 \n"
"---TOMATOES, GRAPE TYPE: DEMAND GOOD. MARKET ABOUT STEADY. Extra services \n"
"included. flats 12 1-pt containers with lids med-lge 9.00 20 lb cartons loose \n"
"med-lge 16.00-17.00 ORGANIC flats 12 1-pt containers with lids med-lge \n"
"7.45-9.00 20 lb cartons loose med-lge 15.95-16.00 \n"
"---TOMATOES, PLUM TYPE: DEMAND GOOD. MARKET ABOUT STEADY. Extra services \n"
"included. Most present shipments from prior bookings and/or previous \n"
"commitments. 25 lb cartons loose Roma exlge 14.95-16.95 occasional higher lge \n"
"14.95-16.95 mostly 14.95 occasional lower med 12.95-14.95 mostly 12.95 \n"
"occasional higher \n\n"
"MEXICO CROSSINGS THROUGH SOUTHERN CALIFORNIA AND SAN LUIS, ARIZONA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---ONIONS GREEN: SUPPLY HEAVY. DEMAND LIGHT. MARKET ABOUT STEADY. Extra \n"
"services included. Most shipments from Mexico transferred to Central California\n"
"for consolidation and distribution. cartons bunched 48s med 6.95-10.85 mostly \n"
"7.00-9.55 few 11.00-11.15 one label 12.75 cartons 2 film bags iceless 24 \n"
"bunches per bag 6.00-12.50 mostly 8.45-10.55 few 13.75 one label 14.25 cartons \n"
"4 film bags iceless 12 bunches per bag 6.00-12.50 mostly 8.45-10.55 few 13.75 \n"
"one label 14.25 ORGANIC cartons bunched 48s med 18.50-20.95 occasional higher \n\n"
"MEXICO CROSSINGS THROUGH TEXAS \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2021 Season \n"
"---BROCCOLI: DEMAND MODERATE. MARKET SLIGHTLY LOWER. Wide range in quality and \n"
"condition. 20 lb cartons loose Crown Cut Short Trim 13.00-15.50 mostly \n"
"14.00-14.50 occasional higher \n"
"---CARROTS: DEMAND MODERATE. MARKET ABOUT STEADY. Wide range in price, quality,\n"
"and condition. 50 lb sacks loose jbo 13.00-14.00 \n"
"---CUCUMBERS: DEMAND MODERATE. MARKET ABOUT STEADY. Wide range in price, \n"
"quality and condition. Most present shipments from prior bookings and or \n"
"previous commitments. 1 1/9 bushel cartons med 11.95-13.95 mostly 11.95-12.95 \n"
"occasional higher fr qual 6.95-8.95 mostly 7.95-8.95 ord qual 4.95-6.95 mostly \n"
"4.95-5.95 lge 10.95-12.95 mostly 10.95-11.95 few 14.95 ocassional higher \n"
"---PEPPERS, BELL TYPE: SUPPLY LIGHT. DEMAND RED GOOD, YELLOW AND ORANGE FAIRLY \n"
"GOOD. MARKET ORANGE SLIGHTLY HIGHER, OTHERS ABOUT STEADY. Wide range in price \n"
"and quality. GREENHOUSE 11 lb cartons Red jbo 16.00-18.00 mostly 17.00-18.00 \n"
"occasional higher exlge 16.00-18.00 mostly 17.00-18.00 occasional higher lge \n"
"15.00-17.00 mostly 15.00-16.00 Yellow jbo 12.00-14.00 mostly 13.00-14.00 exlge \n"
"12.00-14.00 mostly 13.00-14.00 Orange jbo 12.00-15.00 mostly 13.00-15.00 exlge \n"
"12.00-15.00 mostly 13.00-15.00 \n"
"---PEPPERS, OTHER: DEMAND GOOD AT SLIGHTLY LOWER PRICES. MARKET SLIGHTLY LOWER.\n"
"Wide range in price, quality, condition and size. 1 1/9 bushel cartons Anaheim \n"
"26.00-29.00 mostly 27.00-28.00 occasional higher Jalapeno 15.00-18.00 mostly \n"
"16.00-17.00 Poblano 16.00-18.00 mostly 17.00-18.00 occasional higher Serrano \n"
"15.00-18.00 mostly 16.00-17.00 occasional higher 8 lb cartons Habanero orange \n"
"29.00-32.00 mostly 29.00-30.00 \n"
"---TOMATOES: DEMAND FAIRLY GOOD. MARKET LOOSE MUCH HIGHER, 2 LAYER SLIGHTLY \n"
"HIGHER. Extra services included. 25 lb cartons loose Vine Ripes 4x5 sz \n"
"14.96-16.95 mostly 15.95-16.95 5x5 sz 14.95-16.95 mostly 15.95-16.95 5x6 sz \n"
"13.95-15.95 mostly 14.95 cartons 2 layer Vine Ripes 4x4s 13.95-15.95 mostly \n"
"14.95 4x5s 13.95-15.95 mostly 14.95 5x5s 12.95-14.95 mostly 12.95-13.95 \n"
"---TOMATOES, GRAPE TYPE: DEMAND MODERATE. MARKET PINTS SLIGHTLY HIGHER, OTHERS \n"
"ABOUT STEADY. Wide range in quality and condition. flats 12 1-pt containers \n"
"with lids med-lge 7.95-9.95 mostly 8.95 20 lb cartons loose med-lge 12.95-14.95\n"
"mostly 13.95 \n"
"---TOMATOES, PLUM TYPE: DEMAND LIGHT. MARKET ABOUT STEADY. Extra services \n"
"included. Wide range in quality and condition. 25 lb cartons loose Roma exlge \n"
"12.95-13.95 mostly 12.95 occasional higher lge 11.95-12.95 occasional higher \n"
"med 10.95-11.95 mostly 10.95 occasional higher \n\n"
"OXNARD DISTRICT CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2021 Season \n"
"---CABBAGE: SUPPLY RED LIGHT. DEMAND FAIRLY LIGHT. MARKET RED LOWER, GREEN \n"
"SLIGHTLY LOWER. Extra services included. Wide range in quality and condition. \n"
"50 lb cartons Round Green Type med 18.95-19.95 Red Type med 26.95-30.95 \n"
"---GREENS: DEMAND FAIRLY GOOD. MARKET ABOUT STEADY. Extra services included. \n"
"cartons bunched Kale green 24s 9.95-11.95 mostly 9.95-10.00 Lacinato (Tuscan) \n"
"24s 10.95-13.95 mostly 11.95-13.95 \n"
"---PARSLEY: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. \n"
"cartons bunched Curly 60s 13.95-16.95 mostly 14.95-16.95 Plain 60s 12.95-16.95 \n"
"mostly 14.95-16.95 \n\n"
"SALINAS-WATSONVILLE CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---BROCCOLI: DEMAND FAIRLY LIGHT. MARKET SLIGHTLY LOWER. Extra services \n"
"included. Wide range in quality and condition. cartons bchd 14s 9.55-13.55 \n"
"mostly 10.00-11.75 few 14.45-14.95 occasional lower bchd 18s 10.05-14.05 mostly\n"
"10.50-12.25 few 14.95-15.45 occasional lower 20 lb cartons loose Crown Cut \n"
"10.00-14.85 mostly 11.00-12.75 few 15.50-15.95 Short Trim 12.00-15.85 mostly \n"
"12.00-13.75 few 16.50-16.95 ORGANIC cartons bchd 14s 14.00-22.50 mostly \n"
"16.55-18.75 few 24.95 occasional higher 20 lb cartons loose Crown Cut \n"
"18.00-24.75 mostly 20.55-22.75 few 28.50-28.95 \n"
"---CAULIFLOWER: SUPPLY FAIRLY HEAVY. DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. \n"
"Extra services included. Harvest curtailed by market conditions. cartons film \n"
"wrapped White 9s 8.55-11.75 mostly 8.65-10.00 few 12.55 occasional higher and\n"
"lower 12s 8.45-12.75 mostly 9.45-10.65 few 13.50-13.55 occasional higher 16s \n"
"7.55-11.55 mostly 8.45-9.65 few 12.55 ORGANIC cartons film wrapped White 9s \n"
"9.00-16.50 mostly 13.55-15.50 one label 18.95 12s 12.00-17.50 mostly \n"
"14.50-15.85 few 18.95 16s 12.00-16.50 mostly 12.00-14.50 one label 18.95 \n"
"---CELERY: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included. Wide \n"
"range in quality and condition. cartons 2 dz 12.00-16.75 mostly 13.35-15.00 few\n"
"17.50-18.55 occasional lower 2 1/2 dz 12.00-16.75 mostly 14.06-15.50 few \n"
"17.50-18.55 occasional lower 3 dz 14.06-17.55 mostly 14.06-16.65 one label \n"
"18.45 cartons film bags Hearts 18s 17.06-20.55 mostly 17.50-19.06 few \n"
"21.55-22.55 ORGANIC cartons 2 dz 14.00-17.50 mostly 14.50-16.75 few 18.50 one \n"
"label 20.95 2 1/2 dz 14.50-17.50 mostly 14.50-16.75 few 18.50-18.56 one label \n"
"20.95 cartons film bags Hearts 18s 14.50-18.95 mostly 16.00-17.85 occasional \n"
"higher \n"
"---LETTUCE-ICEBERG: DEMAND FAIRLY GOOD. MARKET SLIGHTLY HIGHER. Extra services \n"
"included. Wide range in quality and condition. cartons flm lined 24s \n"
"15.55-18.75 mostly 15.55-17.50 few 19.00-19.65 few 12.00-12.95 24s flmwrpd \n"
"16.55-19.75 mostly 16.55-18.50 few 20.00-20.65 few 13.00-13.95 30s flmwrpd \n"
"14.00-15.55 mostly 14.00-14.75 occasional higher ORGANIC cartons 24s flmwrpd \n"
"16.00-20.50 mostly 16.00-18.50 12s flmwrpd 10.00-12.95 mostly 10.00-11.85 \n"
"---LETTUCE-OTHER: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra services \n"
"included. Wide range in quality and condition. cartons Boston 24s 10.50-14.75 \n"
"mostly 10.50-12.55 few 15.50-15.75 Green Leaf 24s 8.56-11.95 mostly 9.50-10.65 \n"
"few 12.06-12.50 one label 15.75 Red Leaf 24s 8.56-11.75 mostly 9.50-10.65 few \n"
"12.05-12.75 ORGANIC cartons Green Leaf 24s 12.00-16.75 mostly 12.00-14.75 Red \n"
"Leaf 24s 12.00-16.75 mostly 12.00-14.75 \n"
"---LETTUCE-ROMAINE: DEMAND HEARTS FAIRLY LIGHT, 24S MODERATE. MARKET ABOUT \n"
"STEADY. Extra services included. Wide range in quality and condition. cartons \n"
"24s 10.00-13.75 mostly 10.15-11.95 occasional higher cartons 12 3-count \n"
"packages Hearts 12.85-17.95 mostly 14.50-16.75 few 18.05-18.75 occasional \n"
"higher cartons film lined Hearts 48s 13.85-19.95 mostly 16.50-18.75 few \n"
"20.00-20.75 ORGANIC cartons 24s 16.50-18.55 few 20.00-20.75 cartons 12 3-count\n"
"packages Hearts 13.85-20.50 mostly 17.55-18.95 few 22.50-22.75 \n\n"
"SAN JOAQUIN VALLEY CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---CORN-SWEET: SUPPLY VERY LIGHT. DEMAND GOOD. Extra services included. \n"
"cartons/crates White 4 dz min 28.95-37.95 mostly 33.95-34.95 occasional higher \n"
"---PEPPERS, BELL TYPE: DEMAND GOOD. MARKET ABOUT STEADY. Extra services \n"
"included. 1 1/9 bushel cartons Green exlge 24.95-30.95 mostly 28.95 lge \n"
"20.95-26.95 mostly 22.95-23.95 irreg sz fr qual 18.95-23.95 mostly 18.95-20.95 \n"
"occasional higher Red irreg sz fr qual 28.95-32.95 mostly 29.95-30.95 \n\n"
"SANTA MARIA CALIFORNIA \n"
" \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---BROCCOLI: DEMAND SHORT TRIM MODERATE, OTHERS LIGHT. MARKET SLIGHTLY LOWER. \n"
"Extra services included. cartons bchd 14s 8.50-11.85 mostly 10.00-11.00 20 lb \n"
"cartons loose Crown Cut 10.00-13.00 mostly 10.00-12.00 Short Trim 11.00-14.00 \n"
"mostly 11.00-13.00 \n"
"---CAULIFLOWER: DEMAND LIGHT. MARKET ABOUT STEADY. Extra services included. \n"
"Most present shipments from prior bookings and/or previous commitments. cartons\n"
"film wrapped White 9s 6.00-8.00 mostly 6.00-7.00 12s 6.00-9.15 mostly 7.00-8.35\n"
"few 10.15 \n"
"---CELERY: DEMAND MODERATE. MARKET 2 DOZEN ABOUT STEADY, OTHERS SLIGHTLY LOWER.\n"
"Extra services included. cartons 2 dz 10.50-14.00 mostly 11.00-12.65 occasional\n"
"higher 2 1/2 dz 10.50-14.00 mostly 11.00-12.65 occasional higher 3 dz \n"
"10.50-14.00 mostly 10.50-12.50 occasional higher \n"
"---LETTUCE-ICEBERG: DEMAND FAIRLY GOOD. MARKET ABOUT STEADY. Extra services \n"
"included. Wide range in price, quality and condition. Most present shipments \n"
"from prior bookings and/or previous commitments. cartons flm lined 24s \n"
"10.00-12.15 mostly 10.00-11.00 occasional higher 24s flmwrpd 11.00-14.15 mostly\n"
"11.00-12.65 few 15.00 occasional higher \n"
"---LETTUCE-OTHER: SUPPLY VERY LIGHT AND IN FEW HANDS. DEMAND LIGHT. MARKET \n"
"LOWER. Extra services included. cartons Green Leaf 24s 8.00-11.85 mostly \n"
"9.00-9.50 Red Leaf 24s 9.50-10.85 mostly 9.50 \n"
"---LETTUCE-ROMAINE: DEMAND LIGHT. MARKET ABOUT STEADY. Extra services included.\n"
"cartons 24s 8.00-11.85 mostly 8.00-10.00 cartons 12 3-count packages Hearts \n"
"11.00-14.00 mostly 11.00-12.85 \n\n"
"SOUTH & CENTRAL CALIFORNIA AND MEXICO CROSSINGS THROUGH SOUTHERN CALIFORNIA \n"
" AND SAN LUIS, ARIZONA \n"
"Sales F.O.B. Shipping Point and/or Delivered Sales, Shipping Point Basis \n"
" \n"
"VEGETABLES \n"
"2022 Season \n"
"---BRUSSELS SPROUTS: DEMAND MODERATE. MARKET ABOUT STEADY. Extra service \n"
"included. Wide range in quality and condition. 25 lb cartons med 18.45-23.15 \n"
"mostly 19.50-21.45 few 24.75-24.95 \n"
"---PEAS GREEN: DEMAND MODERATE. MARKET ABOUT STEADY. Extra services included 10\n"
"lb cartons Snow Peas Decalyxed 14.00-20.95 mostly 16.00-18.00 few 21.35 \n"
"occasional lower Sugar Snap Peas Decalyxed 16.00-18.95 mostly 17.95-18.95 few \n"
"21.35 occasional lower \n"
"---RADISHES: DEMAND FAIRLY LIGHT. MARKET ABOUT STEADY. Extra service included. \n"
"Wide range in quality and condition. cartons bunched Red 24s 10.95-14.85 mostly\n"
"11.95-13.55 occasional higher 48s 16.45-19.25 mostly 17.45-18.95 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.