$re = '/\(SERIALINTERFACE\){\n(.*?)}/s';
$str = '
(SERIALINTERFACE){
["baudrate","9600"];
["delay" , "100"];
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);