re = /\(SERIALINTERFACE\){\n(.*?)}/
str = '
(SERIALINTERFACE){
["baudrate","9600"];
["delay" , "100"];
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end