import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+ (\\w+) 3160 211 50 0(\\w+)\\d{3} .+$";
final String string = "RD32 MK12001 3160 211 50 02100123001 SERVER LOCAL - STREET \n"
+ "RD32 MK13103 3160 211 50 02100124001 SERVER LOCAL - CITY \n"
+ "RD32 J4834-00009-92051 MRDOOP 3160 211 50 021005237001 SERVER GIVEN NAME \n"
+ "RD32 B5509-00000-00522 JPPK 3160 211 50 02123133001 SERVER GIVEN NAME \n";
final String subst = "$1 C$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}