$re = '/^.+ (\w+) 3160 211 50 0(\w+)\d{3} .+$/im';
$str = 'RD32 MK12001 3160 211 50 02100123001 SERVER LOCAL - STREET
RD32 MK13103 3160 211 50 02100124001 SERVER LOCAL - CITY
RD32 J4834-00009-92051 MRDOOP 3160 211 50 021005237001 SERVER GIVEN NAME
RD32 B5509-00000-00522 JPPK 3160 211 50 02123133001 SERVER GIVEN NAME
';
$subst = "$1 C$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;