$re = '/\b\d+(?:\.\d+)?[a-zA-Z]?(?!\S)/m';
$str = '123.2A
123
1234A
123.2All this extra text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);