re = /\b\d+(?:\.\d+)?[a-zA-Z]?(?!\S)/m
str = '123.2A
123
1234A
123.2All this extra text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end