#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=:).*(?=!)"
Local $sString = ":>Test!1.221ddba.0_31df0888d4d13e9456a2bdafc93437ff@~127.0.0.1 JOIN UUNN :%#Test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")