re = /(?<=:).*(?=!)/
str = ':>Test!1.221ddba.0_31df0888d4d13e9456a2bdafc93437ff@~127.0.0.1 JOIN UUNN :%#Test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end