import re
regex = re.compile(r"T\s?=\s?-?\d+\.\d+\s?to\s?\d+\.\d+\s?K")
test_str = ("Table 1. Coefficients for the polynomial expansion equations. Standard deviations (see introduction):\n"
"σ = 5.5832 x 10-1 (low temperature range), σc,w = (4.8307 x 10-1 combined temperature ranges, weighted),\n"
" \n\n\n\n"
"σc,uw = 3.4016 x 10-1 (combined temperature ranges, unweighted)\n"
" T = 176.15 to 400.00 K T = 400.00 to 512.64 K Coefficient \n"
"ρ = A + BT + CT 2 + DT 3 + … ρ = [1 + 1.75(1 - T/Tc)1/3 + 0.75(1 - T/Tc)]\n"
" [ρc + A(Tc -T ) + B(Tc - T )2 + C(Tc - T )3 + D(Tc - T )4]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")