$re = '/{{[a-zA-z0-9]*|}}/m';
$str = 'Blah blah {{tag1}} blah {{tag2}} blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);