$re = '/^([^@\s]+@[^@\s]+\.(?!gov(?:\s|$))[^@\s.]+)/mi';
$str = 'abc123@abc.c # \'o\' is in \'gov\' so it ends the returned string there
456@email.edu
governmentemail@governmentaddress. #\'.gov\' omitted
test@test.gov
test.test@test.org.gov.test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);