import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<book>\\S+)\\s*(?<chapters>(?<from>[0-9]+)(\\s*-\\s*(?<to>[0-9]+))*)";
final String string = "Matthieu 2 - 14\n"
+ "Jean 2-10\n"
+ "Apocalypse 12-22\n"
+ "Genèse 1- 10\n"
+ "Nombres 1- 10\n"
+ "Luc 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}