// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<book>\S+)\s*(?<chapters>(?<from>[0-9]+)(\s*-\s*(?<to>[0-9]+))*)").unwrap();
let string = "Matthieu 2 - 14
Jean 2-10
Apocalypse 12-22
Genèse 1- 10
Nombres 1- 10
Luc 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}