#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<userFields>(.*?)</userFields>"
Local $sString = "<ComponentSelectedItems>" & @CRLF & _
"<userFields>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
"</userFields>" & @CRLF & _
"</ComponentSelectedItems>" & @CRLF & _
"<ComponentSelectedItems>" & @CRLF & _
"<userFields>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
"</userFields>" & @CRLF & _
"</ComponentSelectedItems>" & @CRLF & _
"<ComponentSelectedItems>" & @CRLF & _
"<userFields>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
"</userFields>" & @CRLF & _
"</ComponentSelectedItems>" & @CRLF & _
"<ComponentSelectedItems>" & @CRLF & _
"<userFields>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
"</userFields>" & @CRLF & _
"</ComponentSelectedItems>" & @CRLF & _
"<ComponentSelectedItems>" & @CRLF & _
"<userFields>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
" <Field></Field>" & @CRLF & _
"</userFields>" & @CRLF & _
"</ComponentSelectedItems>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")