import Foundation
let pattern = #"<userFields>(.*?)</userFields>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
<ComponentSelectedItems>
<userFields>
<Field></Field>
<Field></Field>
<Field></Field>
</userFields>
</ComponentSelectedItems>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}