using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Linux(;?\s?)?([A-Za-z0-9_]*)(;|\)|\s)?";
string input = @"Linux; _86x64daw ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}