$re = '/Linux(;?\s?)?([A-Za-z0-9_]*)(;|\)|\s)?/m';
$str = 'Linux; _86x64daw ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);