#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[tysjod].*|(?!0+$) *\d+ *$)"
Local $sString = "Test cases for matching:" & @CRLF & _
"yes" & @CRLF & _
"1" & @CRLF & _
"1010" & @CRLF & _
" 0 " & @CRLF & _
"Test cases for not matching:" & @CRLF & _
"no" & @CRLF & _
"0" & @CRLF & _
"00" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")