using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[tysjod].*|(?!0+$) *\d+ *$)";
string input = @"Test cases for matching:
yes
1
1010
0
Test cases for not matching:
no
0
00
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}