package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*\s*tw\s*\*\/\s*"([^"]*)"`)
var str = `const props = defineProps<{
type: string;
}>();
const { type } = toRefs(props);
const tagClass = computed(() => {
return type.value === "1"
? /*tw*/ "bg-blue-100 text-blue-800 dark:bg-blue-200 dark:text-blue-800"
: type.value === "2"
? /*tw*/ "bg-rose-100 text-rose-800 dark:bg-rose-200 dark:text-rose-800"
: null;
});`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}