const regex = /\/\*\s*tw\s*\*\/\s*"([^"]*)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*\\s*tw\\s*\\*\\\/\\s*"([^"]*)"', 'gm')
const str = `const props = defineProps<{
type: string;
}>();
const { type } = toRefs(props);
const tagClass = computed(() => {
return type.value === "1"
? /*tw*/ "bg-blue-100 text-blue-800 dark:bg-blue-200 dark:text-blue-800"
: type.value === "2"
? /*tw*/ "bg-rose-100 text-rose-800 dark:bg-rose-200 dark:text-rose-800"
: null;
});`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}