package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+([0-9,])+[0-9]+$`)
var str = `1,2,3,49,5
1,2,3,45,
,12,4,2,67
1,2 3,4,5,6
11,2,3,49,55`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}