$re = '/^[0-9]+([0-9,])+[0-9]+$/m';
$str = '1,2,3,49,5
1,2,3,45,
,12,4,2,67
1,2 3,4,5,6
11,2,3,49,55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);