re = /^(?:[A-Z]+\/\/){2}[A-Z]+\K\/\//m
str = 'ABC//DEG//IJK//LMN//OPQ//rstuvwxyz
BCA//EGD//JKI//MNL//PQO//stuvwxyzr
ACB//DGE//IJK//LNM//OQP//rstuvwxyz
ABC//DEG//IJK//LMN//OPQ//rstuvwxyz
CAB//GDE//KIJ//NLM//QOP//rstuvwxyz
BAC//EDG//JIK//MLN//POQ//rstuvwxyz'
subst = '\\\\\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result