$re = '/- \K[\w:\']+(?: [\w:\']+){4}/m';
$str = 'OBJ: redacted - We can\'t save this record because the “FBE Record-Trigger: redacted After Save” process failed. Give your Salesforce admin these details. This error occurred when the flow tried to update records: CANNOT_EXECUTE_FLOW_TRIGGER: We can\'t save this record because the “FBE Account To Oppty Partner AE” process failed. Give your admin these details. This error occurred when the flow tried to update records: UNABLE_TO_LOCK_ROW: unable to obtain exclusive access to this record or 32 records: 0068z0000025NS1AAM,006t0000003YfgFAAS,006t00000046pFEAAY,0068z0000027ULKAA2,0068z000002YmpsAAC,006t00000046p7bAAA,006t00000046p7OAAQ,0068z0000026AgJAAU,0068z0000029VutAAE,006t00000046p7LAAQ, ... (22 more).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);