import Foundation
let pattern = #"- \K[\w:']+(?: [\w:']+){4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"OBJ: redacted - We can't save this record because the “FBE Record-Trigger: redacted After Save” process failed. Give your Salesforce admin these details. This error occurred when the flow tried to update records: CANNOT_EXECUTE_FLOW_TRIGGER: We can't save this record because the “FBE Account To Oppty Partner AE” process failed. Give your admin these details. This error occurred when the flow tried to update records: UNABLE_TO_LOCK_ROW: unable to obtain exclusive access to this record or 32 records: 0068z0000025NS1AAM,006t0000003YfgFAAS,006t00000046pFEAAY,0068z0000027ULKAA2,0068z000002YmpsAAC,006t00000046p7bAAA,006t00000046p7OAAQ,0068z0000026AgJAAU,0068z0000029VutAAE,006t00000046p7LAAQ, ... (22 more)."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)