using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|`(?>[^`\\]|\\.|``)*`|'(?>[^'\\]|\\.|'')*'|""(?>[^""\\]|\\.|"")*""|(\?{1,2})|(:{1,2})([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*))";
string input = @"INSERT INTO xyz WHERE
a=?
and b=""wha\""t?""
and ??=""cheese""
and `col?`='OK'
and ::col='another'
and last!=:least";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}