$re = '~(?|`(?>[^`\\\\]|\\\\.|``)*`|\'(?>[^\'\\\\]|\\\\.|\'\')*\'|"(?>[^"\\\\]|\\\\.|"")*"|(\?{1,2})|(:{1,2})([a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*))~';
$str = 'INSERT INTO xyz WHERE
a=?
and b="wha\\"t?"
and ??="cheese"
and `col?`=\'OK\'
and ::col=\'another\'
and last!=:least';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);