package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\d+|\W+|a-z]+| +)`)
var str = `123天0氣0真0好+1 ab++cd8+9abcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}