$re = '/([^\d+|\W+|a-z]+| +)/';
$str = '123天0氣0真0好+1 ab++cd8+9abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);