package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\*([^\s*](?:[^*]*[^\s*])?)\*`)
var str = `* n* *n * *bold* * M *
* text* //don't match
******** //don't match
*text * //don't match
* text * //don't match
* text* //don't match
*text* //match
*Hello World !* //match
*a*
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}