import re
regex = re.compile(r"[0-9a-zA-Z.]", flags=re.MULTILINE)
test_str = " honor.watch magic 2 46mm туалетная вода.men 212.vip amd radeon r5.tm.graphics дренажная помпа.si 2100 sauermann смарт часы айфон.watch 6 surf.coffee меню москва semenasad.ru каталог с фото замена стекла на.apple.watch 3"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")