// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9a-zA-Z.]").unwrap();
let string = " honor.watch magic 2 46mm туалетная вода.men 212.vip amd radeon r5.tm.graphics дренажная помпа.si 2100 sauermann смарт часы айфон.watch 6 surf.coffee меню москва semenasad.ru каталог с фото замена стекла на.apple.watch 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}