package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)_(.*)\..*_(.*)`)
var str = `aabb_cc.dd_eeff`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}