using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)_(.*?)(?:\..*)?_(.*)";
string input = @"aabb_cc.dd_eeff
aabb_ccdd_eeff";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}