$re = '/(.*)_(.*?)(?:\..*)?_(.*)/';
$str = 'aabb_cc.dd_eeff
aabb_ccdd_eeff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);