package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})|[A-Z]{2}(?:[A-Z]|\d){13,}$`)
var str = `works as expected
DE12312341212312312312
GB12ASDF12312312312311
this should match with fallback
NO1212121212121
BG18RZBB91550123456789
this should not match with fallback:
DE1231234121231`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}