$re = '/^(?:GB\d{2}[A-Z]{4}\d{14}|DE\d{20})|[A-Z]{2}(?:[A-Z]|\d){13,}$/m';
$str = 'works as expected
DE12312341212312312312
GB12ASDF12312312312311
this should match with fallback
NO1212121212121
BG18RZBB91550123456789
this should not match with fallback:
DE1231234121231';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);