import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:GB\\d{2}[A-Z]{4}\\d{14}|DE\\d{20})|[A-Z]{2}(?<!DE|GB)(?:[A-Z]|\\d){13,}$";
final String string = "works as expected\n"
+ "DE12312341212312312312\n"
+ "GB12ASDF12312312312311\n\n"
+ "this should match with fallback\n"
+ "NO1212121212121\n"
+ "BG18RZBB91550123456789\n\n"
+ "this should not match with fallback:\n"
+ "DE1231234121231\n"
+ "GB1231231231231";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}